Our service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 12:21 EEST
Monitoring
A fix has been implemented and we're monitoring the results
Posted Oct 25, 2023 - 12:01 EEST
Investigating
Hmm. Something seems to be up with our end user flow.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Oct 25, 2023 - 11:52 EEST
This incident affected: Enterprise USA (API, Webhooks, End User Flow).