Following a period of successful monitoring, we have confirmed that the issue is fully resolved.
System metrics have returned to normal and all services are operational.
Thank you for your patience with us.
Posted Jul 06, 2026 - 22:31 EEST
Identified
We have identified an issue affecting one of our internal components, which is impacting verification decision times. As a result, some verification requests may take longer than usual to receive a decision.
Our team is actively working to resolve the issue as quickly as possible and minimize the impact.
We apologize for the inconvenience and appreciate your patience.
Posted Jul 06, 2026 - 18:15 EEST
This incident affected: Enterprise USA (Verification Decisions).