Our Station/ Hub is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 21:31 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2023 - 21:30 EEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2023 - 21:30 EEST
Update
To minimize the impact of the problem, media files will be temporarily inaccessible for display in Station/Hub when viewing session details. However, you will still be able to access decision data.
We are actively investigating this issue and thank you for your patience.
Posted Jun 22, 2023 - 20:40 EEST
Update
We are still looking into the issue. We appreciate your patience and apologize for the inconvenience.
Posted Jun 22, 2023 - 18:49 EEST
Update
We are continuing to investigate this issue.
Posted Jun 22, 2023 - 18:09 EEST
Investigating
Hmm. Something seems to be up with Station while accessing sessions.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jun 22, 2023 - 17:50 EEST
This incident affected: Enterprise USA (Veriff Station).