Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Jun 12, 2026 - 13:19 EEST

Update

The fix has been successfully deployed.

While services are returning to operational level, our team is actively monitoring system performance and alerts for the next few hours to ensure total stability.

We appreciate your patience while we verify the resolution.
Posted Jun 12, 2026 - 08:45 EEST

Monitoring

The issue has been traced back to an upstream infrastructure outage affecting our platform.
We are working closely with the provider to monitor the resolution and restore full functionality.
Posted Jun 12, 2026 - 06:11 EEST

Identified

The issue has been identified.
Posted Jun 12, 2026 - 05:43 EEST

Update

We are continuing to investigate this issue.
Posted Jun 12, 2026 - 05:25 EEST

Investigating

We are currently investigating potential degraded performance with Verification Decisions.

Our team is working on identifying root cause of the issue that is contributing to delayed decisions and will provide an update shortly.
Posted Jun 12, 2026 - 05:06 EEST
This incident affected: Enterprise Europe (Verification Decisions) and SaaS (Verification Decisions).