Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 00:59 EET

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2026 - 21:15 EET

Monitoring

Decision processing has returned to normal, and no further delays are currently observed. We will continue monitoring to ensure ongoing stability.
Posted Feb 24, 2026 - 21:15 EET

Identified

Due to an issue with one of our components, some sessions may experience a delay in receiving a decision.

We have identified the cause and are currently working on a fix.
Posted Feb 24, 2026 - 19:04 EET
This incident affected: SaaS (Veriff Station) and Enterprise USA (Verification Decisions).