We are experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted May 19, 2020 - 11:49 EEST
Identified
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.
Posted May 19, 2020 - 11:46 EEST
Investigating
We are experiencing some issues with our landing page and verification decisions speeds at the moment.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted May 19, 2020 - 11:41 EEST
This incident affected: Services in America (Verification Decisions) and Services in Europe (Verification Decisions).