Front service and Backoffice experienced some issues
Incident Report for Veriff
Resolved
We had some issues with Back office and end user flow which caused end-users to have problem during the flow.
Issue has been already fixed .

We apologize for any inconvenience!
Posted Mar 04, 2020 - 11:15 EET
This incident affected: Services in Europe (BackOffice, End User Flow).