Our service is experiencing issues

Incident Report for Veriff

Resolved

Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Nov 28, 2023 - 11:22 EET

Monitoring

Fix has been deployed, but to be safe we are monitoring the situation.
Posted Nov 28, 2023 - 11:03 EET

Identified

Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Nov 28, 2023 - 10:36 EET

Investigating

Hmm. Something seems to be up with verification decisions.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Nov 28, 2023 - 10:25 EET
This incident affected: SaaS (Verification Decisions) and Enterprise Europe (Verification Decisions).