Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 22:05 EET

Investigating

We are currently investigating an issue that could be impacting decision time
Posted Jan 15, 2026 - 20:50 EET
This incident affected: SaaS (Verification Decisions).