Service Outage
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Dec 27, 2019 - 12:53 EET
Update
We are having a DDOS attack and our team is working on it
Posted Dec 27, 2019 - 11:48 EET
Investigating
Our services are going through difficulties at the moment . Our dedicated team of engineers is working hard to sort them out as quickly as possible. We apologise for any inconvenience, will update shortly.
Posted Dec 27, 2019 - 11:48 EET
This incident affected: Services in Europe (Veriff Station, BackOffice, End User Flow).