Station currently unavailable

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:42 EEST

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 10:41 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 10:33 EEST

Identified

Hello.

We want to notify you that Station (https://station.veriff.com/login) is currently unavailable as a result of recent maintenance. Access to service is is expected to recover within next 30 minutes. We will continue to monitor the situation and let you know once access recovers

Sorry for any inconvenience this may cause!
Posted Oct 21, 2025 - 10:33 EEST
This incident affected: SaaS (Veriff Station).