Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Jul 29, 2022 - 15:07 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2022 - 14:50 EEST
Update
We are continuing to investigate this issue.
Posted Jul 29, 2022 - 14:38 EEST
Investigating
Hmm. Something seems to be up with our verification engine which is causing session generation to fail.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jul 29, 2022 - 14:32 EEST
This incident affected: Enterprise USA (API) and Enterprise Europe (API).