Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 10, 2025 - 12:00 EEST
Scheduled
Hi there! Just wanted to flag you that we have an urgent maintenance on our database, that will take 60 minutes to complete. During this time, users might notice some interruptions for about a minute. Once it’s done, everything will be working smoothly again. For anything else, please contact us.
Sorry for any inconveniences this may cause.
Posted Apr 09, 2025 - 18:16 EEST
This scheduled maintenance affected: Enterprise USA (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting).