Our verification engine is experiencing an issue
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 10:34 EEST
Investigating
We are experiencing some issues with our verification engine.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Oct 14, 2021 - 10:26 EEST
This incident affected: Services in Europe (Verification Decisions).