Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 11:17 EET
Update
We are continuing to investigate the root cause. We sincerely apologize for any inconvenience this may have caused.
Posted Nov 10, 2021 - 11:12 EET
Investigating
We are experiencing some issues with our verification engine which can cause longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Nov 10, 2021 - 08:33 EET
This incident affected: Services in Europe (Verification Decisions).