Our Veriff station service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Oct 20, 2021 - 10:28 EEST
Update
We are continuing to investigate this issue.
Posted Oct 20, 2021 - 10:27 EEST
Investigating
We are experiencing some issues with our Veriff Station
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Oct 20, 2021 - 10:26 EEST
This incident affected: Services in Europe (API, Veriff Station).