Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 20:02 EET
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Nov 15, 2021 - 19:55 EET
Identified
We are experiencing some issues with our verification engine which can cause longer decision times.
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.

We apologize for any inconvenience!
Posted Nov 15, 2021 - 19:44 EET
This incident affected: Services in Europe (Verification Decisions).