Our BackOffice internal service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Apr 28, 2020 - 19:14 EEST
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Apr 28, 2020 - 18:22 EEST
Update
We are continuing to investigate this issue.
Posted Apr 28, 2020 - 18:21 EEST
Investigating
We are experiencing some issues with our BackOffice internal service. This can cause delays in verification decision making.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Apr 28, 2020 - 18:13 EEST