Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 11:36 EEST
Monitoring
All seems good. But to be safe, we are still keeping a close eye on everything.
Posted Jul 23, 2020 - 10:54 EEST
Investigating
We are experiencing some issues with our verification engine which can cause slightly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Jul 23, 2020 - 10:29 EEST
This incident affected: Services in Europe (Verification Decisions).