Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Sep 09, 2021 - 11:21 EEST
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Sep 09, 2021 - 10:47 EEST
Identified
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.
Posted Sep 09, 2021 - 10:45 EEST
Investigating
We are experiencing some issues with our verification engine which can cause slightly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Sep 09, 2021 - 10:29 EEST
This incident affected: Services in Europe (Verification Decisions).